help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: customization of browse-url has no effect


From: Lute Kamstra
Subject: Re: customization of browse-url has no effect
Date: Thu, 08 May 2003 17:42:42 +0200
User-agent: Gnus/5.1001 (Gnus v5.10.1) Emacs/21.3 (gnu/linux)

upro <address@hidden> writes:

> address@hidden (Johan Bockgård) writes:
>
>> upro <address@hidden> writes:
>>
>>> Lute Kamstra <address@hidden> writes:
>>
>>>> 3) you have a default.el that does this. To test the latter
>>>> possibility, put
>>>>
>>>> (setq inhibit-default-init t)
>>>>
>>>> in your .emacs to prevent loading default.el.
>>
>>> You're great - with inhibit-default-init in .emacs it finally works!
>> [...]
>>> How come my custzom variable was not taken?
>>
>> Point 3) above.
>>
>> M-x locate-library RET default RET
>>
>> will tell you where the file is.
>
> Oops - strange enough I don't have a file default.el... 

Really?  But, your Emacs does behave differently (i.e., with respect
to setting browse-url-browser-function on startup) when you put (setq
inhibit-default-init t) in your .emacs?  Amazing.  At this point I
would start grepping my hard disk.  ;-)

> How can a default value override my browse-program customization of
> there is no default.el file?!?

I'm baffled.

> Should I try to find one? I've been fine without until now...

There is no need to get one.  It's just that its presence would
explain the problem you were experiencing.

Lute.

-- 
(spook) => "Perl-RSA CNCIS sweep"
(insert-file-contents "~/.signature") => (error "`~/.signature' too rude")


reply via email to

[Prev in Thread] Current Thread [Next in Thread]