help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [newbie] emacs flyspell not understands well accented chars


From: Oliver Scholz
Subject: Re: [newbie] emacs flyspell not understands well accented chars
Date: Mon, 02 Jun 2003 18:54:15 +0200
User-agent: Gnus/5.090019 (Oort Gnus v0.19) Emacs/21.3.50 (gnu/linux)

Mario Giammarco <address@hidden> writes:

> Oliver Scholz wrote:

[code]

>> But replace <italian-dictionary> with the name of the Italian
>> dictionary on your system.
>> 
> I am doing something wrong I suppose because when I start flyspell it asks
> for /usr/lib/ispell/italianx.hash and similar (it seems to ignore -d
> italian)

Well, it's possible that you did something wrong. But what exactly
did you do?

To test, what I have suggested, I have downloaded an Italian
dictionary for my GNU/Linux system now, installed it and put the stuff
I posted previously into my .emacs, thereby replacing
"<italian-dictionary>" with "italian". (This is Debian stable.) I then
set my language environment to "Latin-9"[1], visited a new file,
inserted perché and did `M-x flyspell-mode RET'.

Perfect. Works as expected. No problems.

So what is your operating system? What did you put into your .emacs?
Is there any other stuff w.r.t. ispell in you configuration?

>>> BTW: I tried ispell without emacs and it shows strange things:
>>>
>>> perchè is perchM-i
>> 
>> What does that mean? Did you run ispell from a shell?
>
> Yes I ran it on a shell.
[...]

Sorry, I can't reproduce this. My language environment outside of
Emacs is serverly messed up (I never cared about it ...). Maybe
somebody else has a clue.

    Oliver

Footnotes: 
[1]  Uh, oh, Karma-lossage ...

-- 
14 Prairial an 211 de la Révolution
Liberté, Egalité, Fraternité!


reply via email to

[Prev in Thread] Current Thread [Next in Thread]