[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: postscript to lisp, plisp package error - Invalid read syntax: "#"

From: Marco Antoniotti
Subject: Re: postscript to lisp, plisp package error - Invalid read syntax: "#"
Date: Mon, 16 Feb 2004 18:24:34 -0500
User-agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4) Gecko/20030624 Netscape/7.1

Henna wrote:
This help is requested in connection with the plisp package
written by John Peterson of yale.

I am trying to use it and finding errors. I have no lucid
lisp or any other, other than the emacs lisp. I have
tried to (require 'cl) without error.

(require 'cl) just gives you some compatibility with Common Lisp from Emacs Lisp. The two dialects are quite different.

You should get one of the Common Lisp implementations off the net. The sites or are excellent starting points.

I have renamed all files in plisp to be .el from .lisp since that is what
emacs seems to expect. This gave more success in the next loading
command. I have also set the "load-path" variable to include both
the compiler and compiler/common-lisp directories.

(2) I have tried to load build.el as follows inside emacs:

(load "/home/henna/plisp/compiler/build.el") CTRL-x CTRL-e

The error I get in minibuffer is:

Invalid read syntax: "#"

Is there a simple method to solve this?

No. This is one of the fundamental differences between Common Lisp and Emacs Lisp. Get a Common Lisp.

It will save you time and eventually it will be better.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]