[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Cannot open load file: disp-table - error running batch with EMACSLOADPA

From: Drew Adams
Subject: Cannot open load file: disp-table - error running batch with EMACSLOADPATH
Date: Tue, 24 Feb 2004 18:09:02 -0800

If I define environment variable EMACSLOADPATH (as anything at all - whether
a correct path or not), I can't seem to get emacs to run in batch.

I'm running emacs 20.7 on Solaris. Actually, I run an xterm (with or without
a window manager) on the box remotely, using Tarantella.

Emacs works fine interactively; I just can't use it in batch mode with
variable EMACSLOADPATH. If EMACSLOADPATH is undefined, I can run emacs OK in
batch (but of course I can't load libraries, then).

If EMACSLOADPATH is defined at all, I get this error:

  Cannot open load file: disp-table

disp-table is not a library of mine that I load (consciously). It appears to
be a built-in library that is getting loaded by default. The only occurrence
of disp-table in the info help is in a discussion of "Single-byte European
Character Support".

It doesn't matter what the options to emacs -batch are, and it doesn't seem
to have anything to do with any site file:

  emacs -batch
  emacs -batch -q          [-batch should imply -q anyway]
  emacs --no-site-file -batch -eval '(message "hello")'
  emacs -nw --no-site-file -batch -eval '(message "hello")'

  emacs -batch -l mylib
  emacs -batch -l mylib -f myfun

These all give the same error when EMACSLOADPATH is defined. The first four
work OK when it is not defined (the last two need a load-path).

Anyone have an idea on this?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]