help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Emacs on OS X - configuration package


From: Tim McNamara
Subject: Re: Emacs on OS X - configuration package
Date: Sun, 29 Feb 2004 20:19:02 -0600
User-agent: Gnus/5.1006 (Gnus v5.10.6) Emacs/21.3.50 (darwin)

Stefan Monnier <address@hidden> writes:

>> I've looked briefly at this package and since I use Emacs under
>> Apple's X11 interface not Aqua, much of it would have to be altered
>> to be useful for me.
>
> For the X11 build of Emacs, I think we want to stay as "plain Emacs"
> as possible: people who want a Macish feel should use the Carbon
> version.

I use the X11 version because I prefer the way it "feels" to the Aqua
versions, and also because it seems faster under X11 than it did under
Aqua.  However, it would be good for people to have the option to
"Macify" the X11 build if they want- I guess.  But I agree that the
default for X11 should be the default POSIX-type standard unless the
user chooses to change it.

>> The Apple key, a.k.a. the Command (Cmd) key, serves as Meta
>> inconsistently.
>
> What do you mean by inconsistently?

<snip>

>> IME however, this is *highly* inconsistent, and may function
>> differently in Emacs built for Apple's Mac OS X Aqua interface
>> vs. the OS X X11
>
> Inconsistent with what?  Under X11, the Apple key appears as Meta,
> so it seems the defaults are consistent.

Actually, under OS X 10.3.2, built from CVS using Andrew Choi's
patches (./configure --without-aqua --with-x) neither the Cmd key nor
the Alt key function as Meta.  Only the Esc key is available as Meta.
I *think* the problem is aactually in Apple's X11; Cmd or Alt worked
as Meta under XDarwin and OroborOSX in OS X 10.1.5.  In fact, Cmd-w
results in trying to exit Emacs and getting dialog boxes about saving
buffers and newsrc-dribble.

>>>> - Mouse Wheel works
>>>
>>> Didn't it already work before?
>>
>> Inconsistent again.  I find that the mouse wheel worked in some
>> Aqua builds but does not work at all in builds for Apple's X11
>> interface.
>
> Which Emacs build are you referring to?  Have you tried Emacs-CVS
> recently?  I use my mouse wheel all the time with no problem in
> Emacs/X11/Mac.

I built from CVS, umm, maybe 8 weeks ago.  Just after I bought OS X
10.3 and the build I had done under 10.1.5 was broken.  I have only
had the mouse wheel work under Aqua builds (and again I think this is
an Apple problem; the scroll wheel doesn't work in other X11 windows
either).


reply via email to

[Prev in Thread] Current Thread [Next in Thread]