help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: font-locking..fails to set certain strings to bold/italics


From: William Payne
Subject: Re: font-locking..fails to set certain strings to bold/italics
Date: Sat, 24 Apr 2004 16:05:21 +0200

"Jesper Harder" <address@hidden> wrote in message
news:address@hidden
> "William Payne" <address@hidden> writes:
>
> > My problem is that it only sets the color, it fails to set certain
> > types of "strings" to bold/italic as it should. I have been making a
> > lot of changes lately to my .emacs-file but I haven't touched this
> > part and it used to work. Has it to do with me adding a default
> > font? I do that like this:
> >
> > (if (eq window-system 'w32)
> >
> > Please help me! I really would like to know why it stopped working.
>
> See the entry about italics in the Emacs on Windows FAQ:
>
>   <http://www.gnu.org/software/emacs/windows/faq5.html#windows-italics>
>
> -- 
> Jesper Harder                                <http://purl.org/harder/>

Thanks for your reply, Jesper. I have decided that I don't want italic
comments and strings when I program anymore, but I do want to use bold for
certain things, language keywords being one. Using the FAQ, I have been
trying to get it to work, but it's not really working. The settings I will
post below yield bold strings that doesn't appear wide enough, the last
characters seems cut-off..I can post a screenshot if you want. I have the
following settings now:

(if (eq window-system 'w32)
    (progn
      (add-to-list 'load-path "c:/emacs-21.3/cc-mode-5.30.8")
      (setq w32-enable-synthesized-fonts t)
      (set-face-font 'bold
"-raster-Courier-bold-r-normal-normal-16-120-96-96-c-*-iso8859-1")
      (set-default-font
"-raster-Courier-normal-r-normal-normal-16-120-96-96-c-*-iso8859-1")
      (w32-send-sys-command ?\xf030) ; Start as maximized. Or use $
emacs --fullscreen
      ))

[snip]

(custom-set-variables)
(custom-set-faces
 '(font-lock-comment-face ((t (:foreground "Green"))))
 '(font-lock-reference-face ((((class color) (background light))
(:foreground "LightGreen"))))
 '(font-lock-string-face ((t (:foreground "Gray"))))
 '(font-lock-keyword-face ((t (:bold t :foreground "Cyan"))))
 '(font-lock-constant-face ((t (:foreground "Yellow"))))
 '(font-lock-type-face ((t (:bold t :foreground "White"))))
 '(font-lock-variable-name-face ((t (:foreground "Yellow"))))
 '(font-lock-function-name-face ((t (:foreground "Cyan"))))
 '(font-lock-builtin-face ((t (:bold t :foreground "LightGreen")))))

These settings sets the font correctly and sets the types I want bold to
bold, but as I explained above, something is not right because all bold
words are cut off at the end (you can hardly see the last character). Please
help me solve this.

/ William Payne




reply via email to

[Prev in Thread] Current Thread [Next in Thread]