help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: problem with emacs shell mode


From: Jay Cotton
Subject: Re: problem with emacs shell mode
Date: Tue, 21 Sep 2004 11:29:52 -0400

It worked! I set it to true in my .emacs and now it works like a charm. Thanks a bunch!

(setq process-connection-type t)

On Sep 21, 2004, at 10:56 AM, Ian Zimmerman wrote:


Jay> Everything was working great, and I started to think I was finally
Jay> in emacs paradise, and then I opened a shell buffer with M-x
Jay> shell. The problem I encountered is that the shell seems to hold
Jay> onto output of the underlying processes without displaying it on
Jay> the screen. So, for instance, if I run the unix command 'units' at
Jay> the shell prompt, instead of prompting me for what unit I have
Jay> (which is what the program is supposed to do), it appears to
Jay> hang. The only time it will show the output (that I'm aware of) is
Jay> when the underlying process ends. As a result, programs like 'ls'
Jay> appear to work because they aren't interactive - they end almost as
Jay> soon as they are started and their output appears immediately in
Jay> the buffer. But none of my interactive shell scripts work. :(

Tweaking process-connection-type might help, but no promises.  OS X
is weird, as I am learning on my own, unfortunately :-(

--
"It's not true or not."  A reality show producer (real quote)
_______________________________________________
Help-gnu-emacs mailing list
address@hidden
http://lists.gnu.org/mailman/listinfo/help-gnu-emacs






reply via email to

[Prev in Thread] Current Thread [Next in Thread]