[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: AIX 5.2 compile help: minimum config?

From: Peter Dyballa
Subject: Re: AIX 5.2 compile help: minimum config?
Date: Tue, 29 Mar 2005 11:07:01 +0200

Am 28.03.2005 um 17:02 schrieb tph:

The following errors occurred during installation:
error: failed dependencies:
        libXaw3d.a(shr.o) is needed by emacs-X11-21.1-2
        libjpeg.a( is needed by emacs-X11-21.1-2
        libpng.a( is needed by emacs-X11-21.1-2
        libtiff.a(shr.o) is needed by emacs-X11-21.1-2
        libungif.a( is needed by emacs-X11-21.1-2

In what fileset would I find these files?

I do not know enough about AIX 5.2 and its filesets, but these messages mean that the configure script as invoked by SMIT with many '--with- options' could not find the shared libraries for the X11 extension Xaw3d (Athena widgets with a 3 d look) and graphics libraries/extensions JPEG, PNG, TIFF, and GIF. Beside the shared libraries you'll need the C header files too.

To avoid this failing dependancy check and their installation, you can invoke configure with these:

        --without-jpeg --without-png --without-tiff --without-gif

To avoid libXaw3d this might help: --with-x-toolkit=motif

Is there no more up-to-date version of GNU Emacs available on AIX 5.2? The recent version is 21.4 ...



"There's no place like"
                     origin unknown

reply via email to

[Prev in Thread] Current Thread [Next in Thread]