help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: printing from w32 emacs


From: B. T. Raven
Subject: Re: printing from w32 emacs
Date: Tue, 08 Nov 2005 01:11:07 GMT

"Eli Zaretskii" <address@hidden> wrote in message
news:address@hidden
> > From: "B. T. Raven" <address@hidden>
> > Date: Mon, 07 Nov 2005 04:24:24 GMT
> >
> > Has any of you out there been able to print from emacs to your local
> > printer?
>
> Yes, easily.
>
> > My installation is acting as if I am printing to NULL. This is
> > from an emacs 21.3 on win98 to a Canon i850. Neither PRN (default)
or
> > LPT1 works as 'printer-name, quoted or not. Printer works fine if I
> > minimize emacs and run any other windows app incorporating a print
> > function. I had same results with an HP laserjet.
> > I would appreciate any light any of you could throw on this problem.
>
> Did you try to read the manual and follow its advice?  The node
> "MS-DOS printing" (whose name is misleading: it pertains to Windows as
> well) explains how to find out what printer name to use in Emacs and
> how to set up printing in several popular situations.
>
>

Thanks  Lennart and Eli. Eli, yes I did read it, more than once. I think
I even understood everything except the part about printing on a
network. I left 'lpr-command at "" (null string). I tried PRN (and
suffixed with :), LPT1, LPT2, LPT3. Printer light blinks once but
nothing else happens. It's no longer possible to test printing from the
dos shell since COPY FILENAME PRN and TYPE FILENAME > PRN are no longer
supported by dos, at least not under windows. A program (I think by
Lennart) named something like winprint.el can print through Notepad but
it overwrites part of the menu bar and then (fortunately after printing)
crashes Notepad.  I would like to try Lennart's w32-print.el but I am
having trouble finding it. Also I want to stick with the current 21.3
ntemacs rather than change to a windows work-alike. The closest to doing
what I want is possible by going through Ghostscript/Ghostview. With
this in my .emacs:

(setq ps-lpr-command "C:\\Program Files\\Ghostgum\\gsview\\gsprint.exe")
(setq ps-printer-name t)

I can print ordinary files with this setup but if the files contain any
characters outside of the Latin-1 range then a popup dialogue appears
with: "Font for some characters not found..." when I run Postscript
print buffer. I don't know why the emacs file can't just be mapped to
one bit per pixel  and sent to the printer the way the GDI printer works
in Windows.
Lennart, yes the printer works from the browser. I printed out all 9
pages of your web site in living color. Does the w32-print.el also use
the web browser? I want to keep emacs working as much as possible like
the GNU Linux version and do things with the simplest theoretically
possible method. With only the following w32 related tweaks to my
.emacs:
...
 '(indent-tabs-mode nil)
 '(kill-read-only-ok t)
 '(pc-selection-mode t nil (pc-select))
 '(sentence-end "[.?!][]\"')}]*\\($\\| $\\| \\| \\)[
]*")
;; the above used to have a \n in the repexp but the actual
;; linefeed seems not to affect the working of it.
;; changed from default to have dot space interpreted
;; as sentence end.
 '(sentence-end-double-space nil)
 '(tab-stop-list (quote (3 8 20 35 50 70 85 100 115)))
 '(tab-width 3)
...

Calendar display is messed up and text buffers with long lines sometimes
fail to wrap lines (no bent arrow and text to the right of the frame can
only be seen if the line is split with a hard return. When this happens,
point and mouse click no longer correspond but this out-of-synchness can
be corrected by changing font size and then changing it back. Apparently
emacs is doing something with calculating line length based on the
current font character widths.

Thanks again. I guess I'll have to settle for save as utf-8 encoding,
insert as encoded text into an OpenOffice text file and then copy-paste
or print from there.









reply via email to

[Prev in Thread] Current Thread [Next in Thread]