help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: need help with w3


From: Bill Wohler
Subject: Re: need help with w3
Date: Wed, 01 Mar 2006 11:33:38 -0800
User-agent: Gnus/5.11 (Gnus v5.11) Emacs/22.0.50 (gnu/linux)

"address@hidden" <address@hidden> writes:

> I am trying to install w3 on my Emacs.

It's really not that good and no longer maintained. I'd suggest w3m.
For a brief survey of the EMACS HTML browsers, please see:

  http://mh-e.sourceforge.net/manual/html/HTML.html#HTML

> I have Scientific Linux Cern
> 4- a linux distro derived from red hat- there is already installed
> emacs 21.3.5 and xemacs 21.4. With xemacs no problems to install and
> use w3, but if I run emacs there isn't w3. I need to work with
> emacs, without x, Then, I have downloaded w3-4.opre.47 and I tryed
> to install it, using
>
> ./configure --with-emacs=/usr/local/bin/emacs
>
> but when I isuue the command make, I have
> [...]
> File `/root/swAcc/w3/w3-4.0pre.47/lisp/w3.elc' was not compiled in Emacs
> make[1]: *** [w3-cfg.elc] Error 255
> make[1]: Leaving directory `/root/swAcc/w3/w3-4.0pre.47/lisp'
> make: *** [w3] Error 2

>From what you describe, it sounds like w3 has been compiled with
XEmacs. Emacs can't use files that have been byte-compiled with
XEmacs. I don't know how your Red Hat packages work, but maybe a "make
clean" is in order before the make.

> Another problem: because I was not able to install w3, I tryed with
> w3m. But when I run ./configure I have:
>
> checking GC library exists... yes
> checking gc.h usability... no
> checking gc.h presence... no
> checking for gc.h... no
> checking GC header location... /usr /usr/local /root
> checking /usr/include... checking gc.h usability... no
> [..]
> checking for gc.h... no
> configure: error: gc.h not found

If you're installing w3m from source, you'll probably need to build it
within the Emacs source package too. I suspect your answer is in the
release notes.

By the way, I simply install the w3m Debian GNU/Linux (etch) package
for w3m. The Debian Emacs packages take care to byte-compile each
package using all of the installed Emacsen. I used Fedora once, which
is based on Red Hat, and it was a lot like pulling teeth with pliers.
Very painful. Life got much better after switching to Debian. In this
case, you'd say "apt-get install w3m-el" and you'd be done.

-- 
Bill Wohler <address@hidden>  http://www.newt.com/wohler/  GnuPG ID:610BD9AD
Maintainer of comp.mail.mh FAQ and MH-E. Vote Libertarian!
If you're passed on the right, you're in the wrong lane.





reply via email to

[Prev in Thread] Current Thread [Next in Thread]