help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: tramp, emacs, xp, putty


From: Eli Zaretskii
Subject: Re: tramp, emacs, xp, putty
Date: Fri, 05 Jan 2007 21:04:08 +0200

> From: "MitchellCowen" <address@hidden>
> Date: 5 Jan 2007 08:50:03 -0800
> 
> I've been browsing through the list archives but I still don't
> understand how to install tramp to work with normal emacs [not xemacs
> or emacsW32] on XP.  Someone says that emacs22 already has tramp but I
> don't see the binary at http://ftp.gnu.org/gnu/emacs/windows/ .

Emacs 22 was not yet released, but you can find the binary on the same
site as emacsW32: there's an unpatched binary there.

> 1.  Downloaded cygwin
> 2.  Downloaded tramp
> 3.  Unpacked tramp to C:\Program Files\emacs\emacs-21.3\tramp-2.1.7
> 4.  change directory to the tramp-2.1.7 directory
> 5.  ./configure --with-contrib --with-lispdir='C:/Program
> Files/Emacs/site-lisp'  --infodir='C:/Program Files/Emacs/info'
> 
> I get the response
> : command not found4:
> ./configure: line 24: syntax error near unexpected token 'newline'
> ./configure: line 24 'case set -o 2> /dev/null' in *posix *>set -o
> posix;;' sac
> 
> I am assuming this is some problem with cygwin.  Any ideas how to do
> this correctly?

I suggest to get a native Windows binary of Emacs 22, it all works
there out of the box, no customizations in .emacs are necessary.




reply via email to

[Prev in Thread] Current Thread [Next in Thread]