help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Can't compile


From: Xavier Maillard
Subject: Re: Can't compile
Date: Mon, 26 Feb 2007 06:20:05 +0100

Joost Kremers <address@hidden> wrote:

> Xavier Maillard wrote:
> > Weird since it did not compiler with emacs22 and emacs21 (21.2 to
> > 21.4). I tried with emacs22.0.51 and it failed miserably.
> 
> did the eval-and-compile work?

Yes and no. Yes it worked after having added several eval-when
forms but no, I am really not satisfied by this solution.

I would like to know why it solely happens with this defmacro :)
 
> > I am pretty lost here. Could it be a bug into Emacs itself ?
> 
> it's not a bug in emacs, it's a think-o on my part... the code compiled
> fine in my running instance of Emacs, because while developing that code,
> and had manually compiled/eval'ed the relevant defun. then when i
> byte-compiled the entire file, the defun was known, and Emacs did not
> complain.
> 
> i just quit Emacs completely and reloaded the relevant file, got rid of the
> eval-and-compile and byte-compiled the file. now, Emacs complains in the
> same way as XEmacs did before.

I am using a Makefile to byte-compile and thus I am using -q -Q
as my command line switches.

Xavier




reply via email to

[Prev in Thread] Current Thread [Next in Thread]