help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Installing new org-mode version


From: weber
Subject: Re: Installing new org-mode version
Date: 6 Mar 2007 04:56:46 -0800
User-agent: G2/1.0

On 6 mar, 04:12, address@hidden wrote:
> On Mar 5, 5:24 pm, "weber" <address@hidden> wrote:
>
>
>
> > On 4 mar, 17:48, Stefan Monnier <address@hidden> wrote:
>
> > > > I'm not a newbie onemacsanymore, but i'm having trouble to install
> > > >org-mode:/
> > > > The problem is: there is already anorg-modeversion distributed with
> > > >emacs(gnuemacs22 cvs)
> > > > I want to install the last version from the author's site. I cannot do
> > > > a "make install" easily because I am on Winxp.
> > > > I tried just putting the new files on my load-path and doing a load-
> > > > library.
> > > > Even though the right files are being loaded, when I check version
> > > > with command "org-version" I still get 4.56b. (The new version is
> > > > 4.67)
>
> > > What does M-: (find-library-name "org") RET say?
> > > What's your load-path?  Where's your neworg.el?
> > > If that still doesn't explain the problem, then:
> > > where do you modify your load-path in your .emacs?
> > > how/when do you startorg-mode?
> > > I.e. give us a more specific step-by-step description of what you do.
>
> > >         Stefan
>
> > I wonder if only the org-version variable isn't right.
> > I tried to run this code on scratch buffer, and even after that I
> > still get 4.56.
>
> > (defvar org-version "4.67"
> >   "The version number of the fileorg.el.")
>
> > Is this working like it should ?
>
> Defvar sets the value of the variable only the first time it is
> evaluated.
> The second time, if there is already a value, it is not changed by
> defvar anymore.
>
> It sems to me that org.el is already loaded once before you make the
> new version
> available.  A way to do this would be (schematically:
>
> (require 'org)  ; this load the built-in version
> (setq load-path (cons "/path/to/new/org/" . load-path))
> (load-file "org.el") ; this loads the new one.
>
> Hope this helps
>
> - Carsten
>
>
>
> > Thanks
> > weber

Hm... I tried doing a load-file... so probably only the variable is
left wrong ?
Anyway I ended up deleting org.el and org.elc from emacs installation
directory.
Thanks everyone,
weber



reply via email to

[Prev in Thread] Current Thread [Next in Thread]