help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Timezone change in US


From: Chris McMahan
Subject: Re: Timezone change in US
Date: Tue, 13 Mar 2007 08:28:59 -0500
User-agent: Gnus/5.11 (Gnus v5.11) Emacs/22.0.95 (windows-nt)

Eli Zaretskii <address@hidden> writes:

>> From: Chris McMahan <address@hidden>
>> Date: Mon, 12 Mar 2007 10:31:35 -0500
>> 
>> Now that the US has shifted into Daylight Savings, I've discovered
>> that emacs is still displaying DST in the modeline.
>
> Do you mean that the time displayed in the mode line is off by one
> hour?  Or do you mean something else?

Yes, the time displayed in the modeline is off by one hour. It still
reflects the time before the change to Daylight Savings Time.

> If the time is off by one hour, do you see the correct time in the
> lower-right corner of the task bar (in the system tray)?

All other clocks (including the clock that my shell prompt displays)
are correct. I launch emacs from the tcsh shell as well, so if it's
getting the time from there then it should be correct.

>> I've possibly tracked the problem to an incorrect value returned by
>> the function current-time-zone, which is defined in the file
>> editfns.c. It is returning a value of -18000 EST, but it should be
>> -14400 EDT. This is defined in the file editfns.c
>
> Does it help to switch to another time zone via Control Panel
> (including clicking Apply), then switch back to your correct time
> zone?  Also, make sure the "Automatically adjust clock for daylight
> savings time" checkbox is checked.  You don't need to reboot Windows
> XP for that, btw, the effect should be visible as soon as you click
> Apply in the Control Panel's "Date and Time Properties".

A great suggestion, but alas to no avail. I do have the system set up
to automatically adjust for DST as well.

> Finally, did you try to see if the time is displayed correctly in
> "emacs -Q"?

Another great idea. The time is still off by 1 hour, however.

>> Does anybody have a patch for this, or is there something simple and
>> obvious I'm missing.
>
> It works for me without any patches, although not in the US.  How
> (with what version of which compiler) was your Emacs compiled?

I compiled using the latest version of MinGW on 5 March 07
GNU Emacs 22.0.95.1 (i386-mingw-nt5.1.2600) of 2007-03-05 on HY56D61

- Chris

-- 
     (.   .)
  =ooO=(_)=Ooo=====================================
  Chris McMahan | address@hidden
  =================================================


reply via email to

[Prev in Thread] Current Thread [Next in Thread]