help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: JDE and Sun Java6


From: Malte Spiess
Subject: Re: JDE and Sun Java6
Date: Fri, 16 Mar 2007 22:37:47 +0100
User-agent: Gnus/5.110006 (No Gnus v0.6) Emacs/22.0.95 (gnu/linux)

Jiri Pejchal <address@hidden> writes:

> Malte Spiess <address@hidden> writes:
>
>> I need some C-h err I mean help with my jde. I'm running the Emacs
>> snapshot here from Debian Sid and Sun Java6, my jde version is 2.3.5.1.
>>
>> Unfortunately, jde makes some trouble.
>> Each time I type in C-c C-v C-c (jde-compile), I get:
>> ,----
>> | The JDE does not recognize JDK 1.6 javac. Assume JDK 1.5 javac?(yes or no)
>> `----
>>
>> Running a program won't do at all. I always get
>
> I'm running Debian unstable, emacs-snapshot-gtk, cedet from from cvs,
> java 6 and "Hello world" compiles and runs fine.

So does it here (compliling). It's just that I always get this
warning.

And I probably really forgot to set some path for the running of the
program, but somehow I think that was not necessary with Java 1.5. I'm
not 100% sure though.

Other things like the doku seem to be a little problematic, too. I'm
just curious about if that is because of the Java version or because I
have forgotten to set some crucial preferences.

> You can get rid of the warning with customizing jde-jdk-registry and
> setting jdk version to 1.5.0 :-)
>
> '(jde-jdk-registry (quote (("1.5.0" . "/usr/lib/jvm/java-6-sun-1.6.0.00"))))

Yeah, thought of that, too. I just hope that this does not change the
code (in Java 5 compatibility mode or sth. like that).

But probably this is the best solution so far.

> --
> Jiri Pejchal

Greetings

Malte Spiess


reply via email to

[Prev in Thread] Current Thread [Next in Thread]