help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Problem with loading emacs version 21.4


From: Catherine Tran
Subject: Re: Problem with loading emacs version 21.4
Date: Tue, 20 Mar 2007 14:40:19 -0700 (PDT)

Hi Peter,
 
(Switching my email address from address@hidden to address@hidden).
 
I  'pkgadd -d' a few more pkgs that you suggested (see below).
After downloading (blastwave.org) sparc/5.9/emacs-21.4 and its dependencies and pkgadd -d them in the order of the dependencies, it builds me emacs executable /opt/csw/bin/emacs-21.4.  Invoking this '/opt/csw/bin/emacs-21.4 &' give me the following error:
 
ld.so.1: emacs-21.4: fatal: libm.so.2: open failed: No such file or directory
Killed
bash-2.05#
bash-2.05# uname -a
SunOS Rockets 5.9 Generic_118558-33 sun4u sparc SUNW,Sun-Fire-880
bash-2.05# ls -la emacs*
-rwxr-xr-x   2 root     bin      5591108 Sep 21  2005 emacs
-rwxr-xr-x   2 root     bin      5591108 Sep 21  2005 emacs-21.4
-rwxr-xr-x   1 root     bin        17372 Sep 21  2005 emacsclient
bash-2.05#
bash-2.05# pwd
/opt/csw/bin
bash-2.05#
 
'emacsclient'  seems to work, so I am wondering that 1 of 2 things can happen.  Either (1) I am so close to getting it to work but my invocation path is incorrect or (2) it;s not working, could be missing some libraries or other dependencies.  I've 'pkgadd -d' all of the pkgs I can think of including
SUNWjpg
SUNWlibm
SUNWpng
SUNWTiff
SUNWTOO
SUNWxwhl
SUNWxwinc
SUNWXWPLT
SUNWXWRTL
SUNWarc
just to name a few from /var/sadm/pkg. Or something is not built correctly.
Any idea as to what is wrong and what else I can try at this point?
Appreciate your input.

-Catherine


Never miss an email again!
Yahoo! Toolbar
alerts you the instant new Mail arrives. Check it out.
reply via email to

[Prev in Thread] Current Thread [Next in Thread]