help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: how to change mouse pointer color -- solved.


From: George Nurser
Subject: Re: how to change mouse pointer color -- solved.
Date: Fri, 30 Mar 2007 14:52:24 +0100

Problem (sort of) solved.
There is apparently a well known bug in Apple's X11 for Intel that
causes this problem on *all* X11 applications run remotely on Linux.

see
http://www.macosxhints.com/article.php?story=20060316124704289
or
http://lists.apple.com/archives/x11-users/2007/Feb/msg00065.html

There are two solutions.

1. Replace /usr/X11R6/bin/Xquartz by the Xquartz at
http://www.astro.princeton.edu/~cloomis/Xquartz
[the one you get from untarring
http://www.ssec.wisc.edu/~rayg/pub/xfix.tar.gz is an older version]
so:

cd
curl -O http://www.astro.princeton.edu/~cloomis/Xquartz
cd /usr/X11R6/bin/
sudo mv Xquartz old_ Xquartz
sudo cp ~/Xquartz .

2. follow the hint given by Kumbera (last in first page of comments,
in the comments to
http://www.macosxhints.com/article.php?story=20060316124704289)

This involves changing the icon used by the Linux host you are logging onto.
It's probably preferable if it works for you, but I tried method 1.,
it works, so I'm happy.

Hopefully the bug will be fixed in Leopard anyway.

--George Nurser.

On 27 Mar 2007 18:14:39 -0700, address@hidden <address@hidden> wrote:
I have the same problem.  Standard emacs methods of changing the mouse
pointer color have no effect.

I think it's a problem specific to running emacs under X11, displaying
to a Mac X11 server.  Not sure why though.

My current workaround is to change the emacs background color to
"lightblue1".  It's enough contrast to make the yellow pointer show
up, but light enough otherwise.

emacs --background-color=lightblue1





On Mar 15, 3:20 am, "George Nurser" <address@hidden> wrote:
> I am using  v22.0.90.2 of emacs on a linux host, viewed on a Mac
> through X11. It is giving me a yellow mouse pointer
> [hand/arrow/ibeam]. As I use a white background this is not working
> well.
>
> I tried adding
> (set-mouse-color "black")
> to my .emacs, both at the end and beginning but it seems to have no effect.
>
> How do I change its color?
>
> George Nurser.




reply via email to

[Prev in Thread] Current Thread [Next in Thread]