help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Load path and custom compiling cvs on Debian


From: Tim X
Subject: Re: Load path and custom compiling cvs on Debian
Date: Mon, 17 Dec 2007 20:05:52 +1100
User-agent: Gnus/5.11 (Gnus v5.11) Emacs/23.0.50 (gnu/linux)

"John Wells" <address@hidden> writes:

> Guys,
>
> I've learned that anti-aliased fonts don't appear to be supported yet
> on 22, and I've also found that compiling the unicode branch out of
> CVS enables this support.
>
> I've done the compile and it works great...fonts look wonderful.
> However, the problem is the custom compiled emacs doesn't find all my
> pre-installed Debian packaged modes and utilities, like ecb,
> ruby-mode, etc.
>
> It appears that the dpkg's put the various installed files in:
>
> /usr/share/emacs/site-lisp
> /usr/share/emacs22/site-lisp
>
> Then, when I start emacs, these are already there, loaded.
>
> Can someone tell me what configurations settings I need to do to make
> these work with my custom compile? Is it a ./configure option? Is it
> some central emacs config file? Can I inspect where my custom compile
> is looking for modes easily through emacs itself?
>

There are a number of things you need to do to get a CVS build of emacs
work with debian managed elisp packages. The debian version of emacs 22 is
modified to handle this and you will need to do the same sort of
modifications to make this work with your CVS version. 

The best way to do this is grep the files in the lisp directory of the
debian version of emacs 22 for the string 'debian' (make it case
insensitive). 

I can't remember all the files that are modified, but it does include
startup.el and I think paths.el and possibly some others. 

You will also need to make the site-lisp of the installed CVS version
(i.e. probably /usr/local/share/emacs/23.x/site-lisp a symbolic link to
/usr/share/emacs22/site-lisp.

Note also that when emacs is built, aI think it dumps an image of itself to
speedup startup. This means you cannot just modify startup.el and have it
work. You need to modify it and then build emacs. 

At one stage there were some emacs22 snapshot packages being done - maybe
google to see if you can find someone else who has done all the hard work

Tim


-- 
tcross (at) rapttech dot com dot au


reply via email to

[Prev in Thread] Current Thread [Next in Thread]