help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Weird error message "No error" from emacsclientw.exe, runemacs, cygwin


From: Ben Bullock
Subject: Weird error message "No error" from emacsclientw.exe, runemacs, cygwin
Date: Tue, 5 Feb 2008 16:36:10 -0800 (PST)
User-agent: G2/1.0

I am trying to run Windows native emacs from a Cygwin console. I wrote
a Perl script to assist this process:

#!/usr/bin/perl
use warnings;
use strict;
my @args = @ARGV;

sub cygwin2ms_dir
{
    my ($d) = @_;
    $d =~ s@/cygdrive/address@hidden:/@;
    return $d;
}

my $emacsbindir =  "/cygdrive/c/Program\\ Files/Gnu\\ Emacs\\ 22.1/
bin/";

if (!fork) {
#    system($emacsbindir."Emacsclientw.exe --alternate-
editor=".cygwin2ms_dir($emacsbindir)."/runemacs.exe ".join ("
",@args));
    system($emacsbindir."Emacsclientw.exe ".join (" ",@args));
}

This worked at first but then I started getting very strange "No
error" error messages as follows:

http://flickr.com/photos/bnz/2245564484/

Commenting out the line with alternate-editor produced the following
problem as well:

http://flickr.com/photos/bnz/2244770591/

Using "emacs.exe" resulted in having one of those nasty black console
windows which is why I am using "runemacs.exe" above. The script does
a fork so as not to hang Cygwin.

Other pertinent information:

* I have been very careful to repeatedly do "server-start" in Emacs
after starting it (I'll provide an image file if disbelieved).
* Sometimes this script works and sometimes it doesn't. I can't see
what I have done differently.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]