help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Mac OS and Unicode


From: B. Smith-Mannschott
Subject: Re: Mac OS and Unicode
Date: Sat, 9 Feb 2008 10:28:07 +0100




On Feb 8, 2008, at 18:59, Florian Lindner wrote:

Hello,
I'm running GNU Emacs 22.1.1 (i386-apple-darwin9, Carbon Version
1.6.0) von Mac OS X 10.5.1 compiled with Fink. My locale ist
de_DE.UTF-8. Apparently emacs does not use Unicode when saving files.
I have

(set-terminal-coding-system 'utf-8)
(set-keyboard-coding-system 'utf-8)
(prefer-coding-system 'utf-8)

in my .emacs.

I'm doing this in my .emacs and it seems to be working both for 22.1.1 (terminal) and 22.1.50.1 (Emacs.app). I can't say how much of it is necessary and what might be cargo-cult from previous emacs versions...

(setq x-select-request-type '(UTF8_STRING COMPOUND_TEXT TEXT STRING))
(prefer-coding-system 'utf-8)

(when (or (> 21 emacs-major-version)
          (and (= 21 emacs-major-version) (>= 50 emacs-minor-version)))
  (custom-set-variables
   '(current-language-environment "UTF-8")))


Note, however, that my LANG is set differently than yours:

address@hidden:~/.emacs.config]
$ echo $LANG
en_US.utf-8

When I initially installed Mac OS X 10.5, I noted that the man program doesn't work when the language is set to German. I don't know if this has since been resolved, nor do I know if it's limited to just man or perhaps part of a larger problem in OS X.

You might investigate this possibility if the code above doesn't help. Try switching to US English and logging out and back in again and see if it works then.

// ben




reply via email to

[Prev in Thread] Current Thread [Next in Thread]