help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Autoloading failed to define function ispell-region


From: Thierry Volpiatto
Subject: Re: Autoloading failed to define function ispell-region
Date: Wed, 13 Feb 2008 07:50:04 +0100
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/23.0.60 (gnu/linux)

Peter Dyballa <address@hidden> writes:

> Am 12.02.2008 um 18:00 schrieb Ulrich Scholz:
>
>>> Adding a
>>>
>>>         (require 'ispell)
>>>
>>> into your init file? It won't get loaded twice.
>>
>> requiring ispell yields the same error as discribed in my post
>>
>>   Error while loading 50dictionaries-common

Can you check also, if you have differents versions of emacs installed (or been
installed) if /usr/share/emacs/site-lisp or /usr/share/emacs-snapshot/site-lisp
exist and contain dictionaries-common with all it's files.
If not, you will have to uninstall/reinstall one version of emacs or create a
symlink from the valid site-lisp to the other. 


> Sorry, I misunderstood your description! Reading it again, it might
> help then to add the line to 50dictionaries-common.el, quite early.
> Obviously this file does use some ispell function before everything's
> prepared. Another thing might need to be prepared, i.e. set: ispell- 
> program-name. At some time its value was changed from ispell to aspell
> – could be this triggers the error. You can check that  variable's
> value. And you can also check which dictionaries for  aspell and
> ispell are available.
>
> BTW, what is debian support doing? Obviously debian is the culprit
> making GNU Emacs load files that don't come with GNU Emacs.

-- 
A + Thierry
Pub key: http://pgp.mit.edu




reply via email to

[Prev in Thread] Current Thread [Next in Thread]