help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Can't launch emacs in an X window


From: Joel J. Adamson
Subject: Re: Can't launch emacs in an X window
Date: Wed, 27 Feb 2008 09:52:00 -0500
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/23.0.60 (gnu/linux)

"address@hidden" <address@hidden> writes:

> I built GNU emacs, version 22.1, from source on my machine (running
> PCLinuxOS).

I used PCLinuxOS for a while, and I never had any systemic problems
compiling from source.  Is their repository out of date?  Texstar is
very responsive to user requests (at least he was when I was using
PCLinuxOS).  I would urge you to request a current package, as well as
an "emacs-cvs" package, if they're not including Emacs 22.

Here are my configure options for when I build Emacs from CVS on
Slackware 12.0:

========================================

CFLAGS="$SLKCFLAGS" ./configure \
--with-gtk --enable-font-backend --with-xft --prefix=/usr \
--enable-shared --sysconfdir=/etc --localstatedir=/var \
--enable-perl=/usr/bin/perl --build=$ARCH-slackware-linux \
--host=$ARCH-slackware-linux

========================================

I would suggeston PCLinuxOS to use --prefix=/usr/local instead, and of
course the Slackware-specific variables are useless to you ;)

Let me know how it works out for you,
Joel

-- 
Joel J. Adamson
Biostatistician
Pediatric Psychopharmacology Research Unit
Massachusetts General Hospital
Boston, MA  02114
(617) 643-1432
(303) 880-3109


reply via email to

[Prev in Thread] Current Thread [Next in Thread]