help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: SMTP library problem


From: Stephen Berman
Subject: Re: SMTP library problem
Date: Fri, 07 Mar 2008 15:26:07 +0100
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/23.0.60 (gnu/linux)

On Thu, 06 Mar 2008 12:17:23 +0100 David <address@hidden> wrote:

> Stephen Berman <address@hidden> writes:
>> Telnetting to port 25 just times out as above with no port.  I also
>> tried swaks:
>>
>> $ swaks -s mail.myprovider.com
>
> If it is indeed ssmtp you would have to call swaks with
>
> swaks --auth --tls-on-connect -p 465 -s mail.myprovider.com

Ah, thanks.  That works.

>> Again, I can send and receive mail via this server using KMail, which I
>> set up simply by providing the server's FQDN and my user name (KMail
>> figured out the port and authorization method and prompts for my
>> password).  So I expected (and still hope) there's some way to access it
>> with Gnus.
>
> If the above swaks command works, you can use an external tool like
> stunnel to set up the SSL connection. If you have root on the machine,
> you can use stunnel like this
>
> stunnel -f -c -d localhost:2000 -r mail.myprovider.com:465
>
> You should then be able to send mails through your localhost on port
> 2000. Note that the '-f' option lets stunnel run in the foreground for
> testing purposes. If it works, you can omit this option and let stunnel
> run as daemon.

I don't have root access to the machine that hosts the mail server, or
do you mean the machine I use to send mail via the server?  If the
latter, how would I make Gnus aware of the tunnel?

I instrumented smtpmail.el for Edebug and stepped through the code as I
tried to send a mail.  The "freeze" occurred in smtpmail-read-response
at the call to accept-process-output, which is from the Emacs C code.  I
assume this means gnutls is not providing the server what it needs, so
it just waits until it hits the timeout, but I don't know how to proceed
to find out what is going wrong.

Steve Berman





reply via email to

[Prev in Thread] Current Thread [Next in Thread]