[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: utf8 char display in buffer

From: B. T. Raven
Subject: Re: utf8 char display in buffer
Date: Tue, 09 Jun 2009 20:34:47 -0500
User-agent: Thunderbird (Windows/20090302)

ken wrote:
On 06/09/2009 09:03 AM B. T. Raven wrote:
ken wrote:
On 06/08/2009 04:43 PM B. T. Raven wrote:
ken wrote:

C-x ret C-\ latin-4-postfix

then a,e,i,o,u followed by hyphen generate macroned vowels

Fantastic!  But... when I save and close the buffer and then open it up
again, in place of the beautiful and correct characters, there are
little boxes.
After you see then correctly in the buffer do:

C-x ret c utf-8


C-x C-s

Now next time you load that file it should appear correctly.
ā  and ī are not in iso-8859-1 and so you must use a more comprehensive
coding system.

Hmmm... it doesn't.  Doing everything just as you say above, I still get
the little boxes in place of the non-English characters.

When after reloading the buffer, I run "describe-coding-system" on this
buffer, I get:

Coding system for saving this buffer:
  u -- mule-utf-8-unix
Default coding system (for new files):
  u -- mule-utf-8 (alias: utf-8)
Coding system for keyboard input:
Coding system for terminal output:
  0 -- iso-latin-9 (alias: iso-8859-15 latin-9 latin-0)
Defaults for subprocess I/O:
  decoding: u -- mule-utf-8 (alias: utf-8)
  encoding: u -- mule-utf-8 (alias: utf-8)

Priority order for recognizing coding systems when reading files:
  1. mule-utf-8 (alias: utf-8)
  2. iso-latin-1 (alias: iso-8859-1 latin-1)
  3. iso-2022-jp (alias: junet)
  4. iso-2022-7bit
  5. iso-2022-7bit-lock (alias: iso-2022-int-1)
  6. iso-2022-8bit-ss2
  7. emacs-mule
  8. raw-text
  9. japanese-shift-jis (alias: shift_jis sjis)
  10. chinese-big5 (alias: big5 cn-big5)
  11. no-conversion (alias: binary)

  Other coding systems cannot be distinguished automatically
  from these, and therefore cannot be recognized automatically
  with the present coding system priorities.

  The followings are decoded correctly but recognized as iso-2022-7bit-lock:
    iso-2022-7bit-ss2 iso-2022-7bit-lock-ss2 iso-2022-cn iso-2022-cn-ext
    iso-2022-jp-2 iso-2022-kr


I don't know... does utf-8 or mule-utf-8 contain latin-4, greek, and/or
German characters?  (This file has some of each.)

I tried using ‘C-x C-m c utf-8 RET’ prior to 'C-x C-f filename'... but
no joy.  Same no-go with 'C-x C-m c mule-utf-8 RET'.

The fact that these non-English characters display properly in the
buffer initially tells me that I have the requisite fonts installed.  So
what little connection is emacs not making (and how do I tell it to make
that connection)?
If you use utf-8 a lot you can put ;; -*- coding: utf-8[;] -*- into the
first line of the file. I don't know whether that sem in brackets is
needed or not.

Sorry, I should have mentioned that I have this (with the semi-colon) at
the top of the file.

Let me also say that, though the little boxes appear in the emacs
buffer, the proper non-English characters appear when the file is loaded
into firefox.  (Yeah, this emacs file is an HTML page.)

Thanks, all.

Don't know. Your problem has just escalated above my pay grade. I don't know what it means that the files display okay in FF. I just loaded my .emacs into the browser and it looks fine (has many exotic non Latin-1 characters in it). You are using GUI Emacs and not terminal, right. You could try these settings from my ver 22 .emacs, just for fun:

  (set-language-environment               'UTF-8)
        (set-default-coding-systems             'utf-8)
        (setq file-name-coding-system           'utf-8)
        (setq default-buffer-file-coding-system 'utf-8)
        (setq coding-system-for-write           'utf-8)
        (set-keyboard-coding-system             'utf-8)
        (set-terminal-coding-system          'utf-8)
        (set-clipboard-coding-system            'utf-8)
        (set-selection-coding-system            'utf-8)
        (prefer-coding-system                   'utf-8)
(modify-coding-system-alist 'process "[cC][mM][dD][pP][rR][oO][xX][yY]" 'utf-8-dos)

and try C-x ret c utf-8
C-x C-f

to open the file.

or install version 23.x w32 binary into a different directory from here

I don't think you need a .emacs with ver 23 in dealing with utf-8 since its internal representation is unicode.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]