[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

problem migrating to ver. 23.1

From: B. T. Raven
Subject: problem migrating to ver. 23.1
Date: Wed, 19 Aug 2009 11:26:07 -0500
User-agent: Thunderbird (Windows/20090605)

Because of conflicts using HOME environment variable I am running ver. 23.1 (w32 on msw2000) from a batch file with the 2 lines:

c:\emacs-23.1\bin\runemacs --debug-init

Even though I have commented out all references to ucs or ucs-tables from the ver. 23.1 .emacs file, reading of this init file aborts with this backtrace:

Debugger entered--Lisp error: (file-error "Cannot open load file" "ucs-tables")
  mapc(require (ucs-tables))
custom-theme-set-variables(user (TeX-PDF-mode t) (TeX-output-view-style (quote (... ... ... ... ... ... ... ... ... ... ... ... ...)))


(w32-list-proportional-fonts t))
eval-buffer(#<buffer *load*> nil "c:/emacs/.emacs" nil t) ; Reading at buffer position 18084
  load-with-code-conversion("c:/emacs/.emacs" "c:/emacs/.emacs" t t)
  load("~/.emacs" t t)
  #[nil "

Instead of loading the .emacs in C:\emacs-23.1, the ver. 22.3 .emacs is loaded, even though the HOME is supposed to be changed. Also, M-! set shows "home=C:\emacs". What am I not understanding? The last time something like this worked for me I was using msw98 which had true DOS shell ability. Under 2000 do I have run 22.3 and 23.1 as 2 separate users in order to have 2 independent versions of .emacs?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]