help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: How to expertly fold perl or other scripting code.


From: Tim X
Subject: Re: How to expertly fold perl or other scripting code.
Date: Mon, 21 Sep 2009 17:51:01 +1000
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/23.1.50 (gnu/linux)

Harry Putnam <address@hidden> writes:

> Tim X <address@hidden> writes:
>
>> I personally find outline of limited use when it comes to folding
>> code. However, there are a few folding modes out there (check the emacs
>> wiki). I use an old mode called folding.el (which is bundled in the
>> emacs-goodies debian package. It works quite well, is easy to install
>> and provides good functionality. 
>
> Tim, does it byte-compile with emacs 23? for you.
>
> I get what looks like some errors that will require editing.
> When byte-compiling the version offered at the wiki you cite:
>
> http://git.savannah.gnu.org/cgit/emacs-tiny-tools.git/tree/lisp/other/folding.el?h=devel
>
> Maybe the debian pkg has an edited version?
> =====     *     =====     *     =====     *     =====
>  
> In folding-install-keymaps:
> folding.el:2360:8:Warning: `mapcar' called for effect; use `mapc' or `dolist'
>     instead
>
> In folding-event-posn:
> folding.el:2669:7:Warning: `error' called with 1 args to fill 0 format
>     field(s)
> folding.el:2671:5:Warning: `error' called with 1 args to fill 0 format
>     field(s)
>
> In folding-is-hooked:
> folding.el:2702:39:Warning: `write-file-hooks' is an obsolete variable (as of
>     Emacs 22.1); use `write-file-functions' instead.
> folding.el:2703:39:Warning: `find-file-hooks' is an obsolete variable (as of
>     Emacs 22.1); use `find-file-hook' instead.
>
> In folding-install-hooks:
> folding.el:2718:38:Warning: `write-file-hooks' is an obsolete variable (as of
>     Emacs 22.1); use `write-file-functions' instead.
>
> In folding-mode-add-find-file-hook:
> folding.el:2996:37:Warning: `find-file-hooks' is an obsolete variable (as of
>     Emacs 22.1); use `find-file-hook' instead.

Hi Harry,

to be honest, I have no idea. The package is automatically built when
you install it and I've not looked at the compile output. It seems to
work. 

Note that there are at least three packages called folding.el. The one
use is an old one that has ben around for a while (last update I think
was in 2004). There were other versions that attempted to update how
the package owrked using 'newer' emacs features. 

I'll try to look and see what version info I can find in the source
file.

Not sure how many of those 'warnings' are a real issue. The ones about
obsolete versions of functions can be ignored. The ones concerning wrong
number of arguments may be a concern. 


Tim
>

-- 
tcross (at) rapttech dot com dot au


reply via email to

[Prev in Thread] Current Thread [Next in Thread]