[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: emacs won't open files at startup from command line

From: J. David Boyd
Subject: Re: emacs won't open files at startup from command line
Date: Fri, 30 Oct 2009 13:07:37 -0400
User-agent: Gnus/5.1299999999999999 (Gnus v5.13) Emacs/23.1 (cygwin)

address@hidden (J. David Boyd) writes:

> address@hidden (Pascal J. Bourguignon) writes:
>> Tyler Smith <address@hidden> writes:
>>> address@hidden (J. David Boyd) writes:
>>>> I could use some help troubleshooting this.  
>>>> When I start up emacs, it doesn't load the files I name on the command
>>>> line, unless I do an 'emacs -q' to not load any init files.
>>>> Obviously, it must be something in my .emacs file, but I don't see
>>>> anything that I've changed in the recent past.
>>>> Where should I start to debug this?  I don't get any errors when it
>>>> runs, it just refuses to load anything from the command line.
>>> At the risk of stating the obvious, have you tried commenting out all of
>>> your .emacs, then progressively uncommenting it to isolate the lines
>>> that are causing the problem? comment-region (aka M-;) makes this
>>> pretty quick to do.
>> Also, the OP could try:
>>     emacs --debug-init file.txt
>> If the file is not open it might be because there's a bug in ~/.emacs
> That I have tried.  No errors at all...  I was hoping that there would
> be one, but everything loads just fine, no errors, just doesn't load the
> file(s) named on the command line.
> Thanks for the idea, though.

Anyone have any idea which variable in emacs contains the command line?
I'd like to dump it at various points in my .emacs file, and see when it
is getting wiped clean, if that is what is happening...


reply via email to

[Prev in Thread] Current Thread [Next in Thread]