help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Since AUCTeX installation, Gnus won't post on any Usenet group


From: Merciadri Luca
Subject: Re: Since AUCTeX installation, Gnus won't post on any Usenet group
Date: Tue, 04 May 2010 15:45:12 -0000
User-agent: G2/1.0

On Apr 18, 5:32 pm, Ralf Angeli <address@hidden> wrote:
> * Merciadri Luca (2010-04-18) writes:
>
>
>
> > The only thing I have changed in my whole Emacs & Gnus config. is that
> > I installed, some days ago, AUCTeX. Everything went right, and, even
> > the installation's day, Gnus accepted to send articles on Usenet. Now,
> > it won't do anything like that. Why? I changed nothing.
>
> > Here is what I appended to my .emacs after having installed AUCTeX
> > with preview-latex. (I have also tried by removing these lines from
> > the .emacs, which does not change Gnus' behaviour.)
>
> > ==
> > (setq load-path (cons "~/auctex-11.86/" load-path))
> > (setq load-path (cons "~/auctex-11.86/preview/" load-path))
>
> > (load "~/auctex-11.86/auctex.el" nil t t)
> > (load "~/auctex-11.86/preview/preview-latex.el" nil t t)
> > ==
>
> It should not be necessary to add the `preview' subdirectory to
> `load-path' if you installed AUCTeX correctly.  Since preview-latex.el
> is still in the `preview' subdirectory, I presume you did not run `make
> install' as described in the installation instructions of AUCTeX.
I did what was necessary: ./configure, make, make install. I just
added these directories because I thought they were necessary.
> If
> you ignore something like that, you have to be prepared that things go
> wrong.
/
>
> I'd try to disable the lines in your init file you've shown above, then
> restart Emacs and check if the problem is gone.
I tried. Even after having commented out the lines, still nothing
works for posting a message with Gnus.

> If not, start Emacs
> with the --debug-init command line switch in order to check if there is
> something else in your init file leading to an error.
Thanks for this idea. I just tried, and no error is shown.

Actually, I think that AUCTeX is redefining some commands and
shortcuts that are also used in Gnus. How could I modify the AUCTeX's
shortcuts?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]