help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Problem when compiling jedi


From: picca
Subject: Problem when compiling jedi
Date: Tue, 4 Feb 2014 11:17:35 +0100
User-agent: Mutt/1.5.21 (2010-09-15)

Hello,

I am trying to prepare a jedi-mode debian package.
When I am compiling the code with emacs, I get this kind of error

emacsen-common: Handling install of emacsen flavor emacs23
Wrote /etc/emacs23/site-start.d/00debian-vars.elc
Wrote /usr/share/emacs23/site-lisp/debian-startup.elc
Install jedi-mode for emacs
Install jedi-mode for emacs23
install/jedi-mode: Handling install for emacsen flavor emacs23

In toplevel form:
jedi.el:527:1:Warning: misplaced interactive spec: `(interactive)'
jedi.el:527:1:Warning: `(expand expand)' is a malformed function

In jedi:goto-definition:
jedi.el:674:11:Warning: `(other-window other-window)' is a malformed function
jedi.el:674:11:Warning: `(assignment nil)' is a malformed function
jedi.el:689:39:Warning: `t' called as a function

In jedi:related-names--helm:
jedi.el:807:34:Warning: `(helm helm)' is a malformed function
jedi.el:918:52:Error: Wrong type argument: sequencep, subdefs
ERROR: install script from jedi-mode package failed


I know almost nothing about elips, but I would like to learn, since emacs is my 
main developpement tool.
I attache the jedi.el file.
I would like some advice for debuging this issue.

thanks for your help


Frédéric

-- 
GPG public key 4096R/4696E015 2011-02-14
    fingerprint = E92E 7E6E 9E9D A6B1 AA31  39DC 5632 906F 4696 E015
uid  Picca Frédéric-Emmanuel <address@hidden>

GPG public key 1024D/A59B1171 2009-08-11
    fingerprint = 1688 A3D6 F0BD E4DF 2E6B  06AA B6A9 BA6A A59B 1171
uid  Picca Frédéric-Emmanuel <address@hidden>

Attachment: jedi.el
Description: Text document


reply via email to

[Prev in Thread] Current Thread [Next in Thread]