help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Failed to build emacs 24.4 source: /bin/ld error


From: Tory S. Anderson
Subject: Re: Failed to build emacs 24.4 source: /bin/ld error
Date: Thu, 05 Feb 2015 13:10:59 -0500
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/24.3 (gnu/linux)

However, I do have a libpng15 library installed on the machine (it's been there 
all along). Do I need to add another link to it somewhere? 

Eli Zaretskii <address@hidden> writes:

>> From: Sven Joachim <address@hidden>
>> Date: Thu, 05 Feb 2015 18:38:45 +0100
>> 
>> > terminfo.o lastfile.o ../lib/libgnu.a -ltiff -ljpeg -lpng15 -lz -lm
>> > -lgif -lXpm -lgtk-3 -lgdk-3 -lpangocairo-1.0 -lpango-1.0 -latk-1.0
>> > -lcairo-gobject -lcairo -lgdk_pixbuf-2.0 -lgio-2.0 -lgobject-2.0
>> > -lglib-2.0 -lX11 -lXrender -lXft -lasound -lrt -lXrandr -lXinerama
>> > -ltinfo -lgio-2.0 -lgobject-2.0 -lglib-2.0 -lgobject-2.0 -lglib-2.0
>> > -lfreetype -lfontconfig -lfreetype -lpthread -lgio-2.0 -lgobject-2.0
>> > -lglib-2.0 -lm -lz
>> > /bin/ld: cannot find -lpng15
>> 
>> Looks like your libpng installation is messed up.  The include
>> directories indicate you have libpng 1.6 but the linker tries to link
>> with libpng15.so which would come from libpng 1.5.
>
> It could be that one of the other libraries the OP is linking against
> requires 1.5.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]