help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Building emacs errors: libraries present


From: Tory S. Anderson
Subject: Re: Building emacs errors: libraries present
Date: Sat, 07 Feb 2015 08:30:47 -0500
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/24.3 (gnu/linux)

Okay; I've succeeded finally in building by soft-linking all the libraries it 
SHOULD have been finding into the main directories. I'm not sure why it cannot 
use libpng 16 and instead requires 15. E.g. I did this:
    sudo ln -s /anaconda/lib/libpng15.so /usr/lib64/
Taking care of any non-found files that way solved all problems. 

ldconfig looks interesting, but I don't seem to have a manpage on it. 
Unfortunately, it didn't solve the issue. Soft links seemed to do the trick for 
me. 

Alexis <address@hidden> writes:

> Tory S. Anderson writes:
>
>> Okay; I'm making progress. I have identical problems with both 24.4 and 
>> 25.0.5 build processes now. LibPNG is being found! But the gif library is 
>> not. In summary, I get NO configure errors (as long as I do sudo configure), 
>> but I get the following make error (even with sudo make, which I know is 
>> probably a dangerous command):
>>
>>     ./temacs: error while loading shared libraries: libgif.so.7:     cannot 
>> open shared object file: No such file or directory
>>
>> But a find locates it just fine: 
>>
>>     $ sudo find / -name "libgif.so.7" /usr/local/lib/libgif.so.7
>>
>> Indeed, configure apparently found it, right? 
>>
>> Unabridged config and make outputs for those interested: 
>>
>> http://www.toryanderson.com/files/emacs-configure-output.txt 
>> http://www.toryanderson.com/files/emacs-make-output.txt     
>>
>> Any ideas why it can't find libgif? 
>
> Have you run ldconfig(8) after installing libgif?
>
>
> Alexis.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]