help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Company Eclim remove-if error


From: Jude DaShiell
Subject: Re: Company Eclim remove-if error
Date: Wed, 11 Feb 2015 12:03:31 -0500 (EST)

I'm surprised you got as far as you did.  Apparently marmellade repo is 
no longer accessible with I think emacs 24.5 which I thnk is current 
version in archlinux.  A step you forgot which should produce the 
inaccessible error I've just described is to do m-xlist-packages once 
emacs is running.  Find that package you tried installing and hit i on 
it to install it locally then hit x to do the install.  Finally hit q to 
leave list-packages and return to emacs.

On Sat, 6 Dec 2014, typedeph . wrote:

> Hello, I'm a beginner in emacs and have been having trouble setting up this
> emacs eclim package for a while. Although I think I have successfully set
> up eclim I am unable to make company work for it. I have tried to follow
> the instructions on the emacs-eclim website as best as possible: install
> eclim, launch the eclimd server, install emacs-eclim and set up
> emacs-eclim. As I am a beginner my init.el is very short:
> (add-to-list 'package-archives
>          '("marmalade" . "http://marmalade-repo.org/packages/";))
> (add-to-list 'package-archives
>          '("melpa" . "http://melpa.milkbox.net/packages/";))
> (package-initialize)
> 
> (require 'evil)
> (evil-mode 1)
> 
> (setq c-default-style "bsd"
>       c-basic-offset 4)
> 
> (require 'company)
> (add-hook 'after-init-hook 'global-company-mode)
> 
> (custom-set-variables
>  '(eclim-eclipse-dirs '("~/Apps/eclipse"))
>  '(eclim-exectuable "~/Apps/eclipse/eclimd"))
> (setq eclimd-default-workspace "~/workspace")
> 
> (require 'eclim)
> (require 'company-emacs-eclim)
> (company-emacs-eclim-setup)
> 
> Can someone tell me what I'm doing wrong? I get an error the minute I add
> (company-emacs-eclim-setup)
> 
> 

jude <address@hidden>
Twitter: @JudeDaShiell



reply via email to

[Prev in Thread] Current Thread [Next in Thread]