help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: How to update core extensions (Gnus)?


From: Tory S. Anderson
Subject: Re: How to update core extensions (Gnus)?
Date: Tue, 03 Mar 2015 14:06:40 -0500
User-agent: Gnus/5.130012 (Ma Gnus v0.12) Emacs/25.0.50 (gnu/linux)

Thanks. I hope I'm not neurotic about it now :) I find that lately I've been in 
contact with developers of several of these extensions, and so I want to be 
able to test their fixes/improvements as soon as they mention they've updated 
the codebase.

Emanuel Berg <address@hidden> writes:

> address@hidden (Tory S. Anderson) writes:
>
>> Contrary to my long-held belief in the stagnation of
>> the Gnus codebase (I was under the impression it had
>> been untouched since 2009), Gnus has been revived
>> and I want to implement changes that are newer than
>> my current 25.0.5 emacs version. But it looks from
>> my package manager that Gnus isn't something that I
>> can, for instance, grab from Melpa. What's the best
>> practice for updating a core package like this? Can
>> I clone http://git.gnus.org/gnus.git and cause emacs
>> to respect the clone over the built-in? Should I?
>
> You know what they say in Barcelona: If you ever so
> slightly considered taking a psychedelic drug - you
> are thinking, "well, maybe" - then you should do it :)
>
> I hope and think Gnus isn't stagnating. Gnus is part
> of Emacs (it says "Version: 5.13" in gnus.el) so you
> should get updates automagically with the next version
> of Emacs.
>
> What gnus.el version do you have? You can also echo
> the `gnus-version' variable.
>
> By the way, this is your second question about getting
> the latest stuff in unorthodox ways. And you even use
> Emacs 25.0 (I have 24.4). You are not neurotic about
> this, now? :)



reply via email to

[Prev in Thread] Current Thread [Next in Thread]