help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: using use-package


From: Chunyang Xu
Subject: Re: using use-package
Date: Tue, 4 Aug 2015 23:46:19 +0800

On Tue, Aug 4, 2015 at 11:01 PM, Sharon Kimble
<address@hidden> wrote:
> I am having great difficulty in getting "use-package" to work
> successfully.
>
> I have this in my "init.org" -
> --8<---------------cut here---------------start------------->8---
> #+begin_src emacs-lisp
> (use-package fold-this
>   :commands (fold-this-all fold-this fold-this-unfold-all)
>   :defer 2
>   :init
>   :bind (("C-c C-c C-f" . fold-this-all)
>         ("C-c C-c C-d" . fold this)
>         ("C-c C-c C-c" . fold-this-unfold-all)))
> #+end_src
> --8<---------------cut here---------------end--------------->8---
>

A dash ("-") is missing between "fold" and "this" in your second bind.


> which when it is tangled shows -
>
> ╭────
> │Invalid read syntax: . in wrong context
> ╰────
>
> and using "bug-hunter-file" on my "init.el" shows
>
> --8<---------------cut here---------------start------------->8---
> "/home/boudiccas/.emacs.d/org/init.el", line 8029 pos 0:
>   There's a . in wrong context on this position, and that is not valid elisp 
> syntax.
> --8<---------------cut here---------------end--------------->8---
>
> But I've looked at https://github.com/jwiegley/use-package and laid it
> out according to that page, but its still failing, and I don't
> understand why. I'm obviously missing something in my understanding, but
> why is it still failing, and how do I get it to run properly please?
>
> Thanks
> Sharon.
> --
> A taste of linux = http://www.sharons.org.uk
> TGmeds = http://www.tgmeds.org.uk
> Debian 8.0, fluxbox 1.3.7, emacs 24.5.50.3



reply via email to

[Prev in Thread] Current Thread [Next in Thread]