help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: using use-package


From: Michael Heerdegen
Subject: Re: using use-package
Date: Thu, 13 Aug 2015 23:52:10 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/25.0.50 (gnu/linux)

Stefan Monnier <address@hidden> writes:

> My crystal ball tells me that you upgraded Magit from an Emacs where the
> previous Magit was already loaded, and the old (loaded) version
> interfered while byte-compiling the new version.
> [ The typical interference, looks like this: Emacs tries to compile
>   foo-1.el which does (require 'foo-2) to get some macros, but (the old)
>   `foo-2' is already loaded so we end up using the old version of the
>   macros (or the macros may simply not be defined at all).  ]

Sorry, I was not able to fetch the parent message, so I answer to this
one...

I recently had such an issue:
https://github.com/magit/magit/issues/2045.

If the issue is reproducible, it could be worth to report it to the
Magit maintainers.  In my special case, it was fixable from the Magit
side.

BTW, AFAICT since Helm uses async.el for package upgrading we have had
no more of such problems.


Regards,

Michael.




reply via email to

[Prev in Thread] Current Thread [Next in Thread]