help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: What license to use for Emacs libraries?


From: Tassilo Horn
Subject: Re: What license to use for Emacs libraries?
Date: Thu, 20 Aug 2015 06:44:31 +0200
User-agent: Gnus/5.130014 (Ma Gnus v0.14) Emacs/25.0.50 (gnu/linux)

Robert Thorpe <address@hidden> writes:

>> I think one reason why the linux kernel stuck to v2 is that v3 forbids
>> TiVo-ization.
>
> The Linux kernel uses the GPLv2.  The files mention GPLv2 and don't
> say anything about optionally using later versions.
>
> The Linux kernel developers received files from people that were GPLv2
> licensed.  They don't collect copyright attribution paperwork.  Since
> the GPLv3 isn't compatible with the GPLv2 that means they have to keep
> everything in GPLv2.  Otherwise contributors could take legal action
> against them for using their code with a different license.

Yes, that's also an organizational issue.  But Linus has also made it
very clear that he doesn't share the FSF's position on TiVo-ization,
DRM, and patents which are covered by v3 but not by v2.

Bye,
Tassilo



reply via email to

[Prev in Thread] Current Thread [Next in Thread]