help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Quotes do not display correctly


From: Eli Zaretskii
Subject: Re: Quotes do not display correctly
Date: Thu, 07 Apr 2016 18:22:57 +0300

> From: Nick Helm <address@hidden>
> Date: Thu, 7 Apr 2016 09:20:47 +0000
> 
> However, since Emacs 25.x, I have lost the ability to work with some
> quote chars – in particular quote pairs 0x2018 and 0x2019, and 0x201C
> and 0x201D. These are Unicode chars LEFT/RIGHT SINGLE QUOTATION MARK
> and LEFT/RIGHT DOUBLE QUOTATION MARK, or what some people call
> typographic or curly quotes.
> 
> For some reason, Emacs now shows these quote marks in my org-mode
> and markdown-mode buffers (and, as far as I can tell, everywhere else in
> Emacs, including fundamental mode) as either a grave accent (0x60) and
> single quote (0x27) pair, or a double quote (0x22) pair (see screen
> shot). I say shows, because when I do C-u C-x = on these chars, the
> decomposition tells me they are, in fact, the quote chars I expect, Emacs
> just chooses to display them as something else.
> 
> The quotes also appear to have a display table and face applied, but I
> don’t understand the significance of this information, or if it’s a clue to
> solving my problem.

It _is_ a clue.  But to understand what goes wrong, more information
is needed, because Emacs was supposed to set up the display table only
if your display is unable to show the Unicode quote characters.

So please make a bug report, and include there the details about how
you started Emacs.  Also, please make sure you try reproducing the
problem with the latest emacs-25 branch of the Emacs repository, or at
least with the latest pretest of Emacs 25, because it's possible that
this problem was already solved.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]