help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

CC mode 5.33 does not work on Emacs 24.5.1 for Mac


From: Juha Nieminen
Subject: CC mode 5.33 does not work on Emacs 24.5.1 for Mac
Date: Wed, 14 Sep 2016 07:08:44 +0000 (UTC)
User-agent: tin/2.2.1-20140504 ("Tober an Righ") (UNIX) (Linux/3.14.66-grbfs-kapsi (x86_64))

I was wondering if somebody could help me figuring out what the problem is
with this.

I'm using the following version of Emacs on this Mac OS X computer:

GNU Emacs 24.5.1 (x86_64-apple-darwin13.4.0, NS apple-appkit-1265.21)
 of 2015-04-10 on builder10-9.porkrind.org

I downloaded CC Mode 5.33 from http://cc-mode.sourceforge.net/ and
followed the installation instructions.

After adding the directory to the load path, the new CC mode 5.33 is
loaded when I open a source code file ("M-x c-version" gives "Using CC
Mode version 5.33"). However, it does not work properly.

Immediately upon opening a source code file, it gives the error "File
mode specification error: (wrong-type-argument stringp nil)". The text
itself is also only partially colored (eg. some comment lines are
colored while others aren't). Trying to autoindent by pressing tab
gives the error "Wrong type argument: stringp, nil".

Note that:

* My .emacs is not the culprit, as the problem happens even if said file
contains nothing more than the path-setting line

(add-to-list 'load-path "~/software/cc-mode-5.33/")

* The problem happens even if I launch emacs with the options
"-Q -L ~/software/cc-mode-5.33" or the option "--no-site-file".

* The problem does *not* happen if I run an older emacs (22.1.1)
pre-installed in this system (which, however, seems to be text
mode only, with no GUI support).

* The problem does *not* happen with a Windows port of emacs.
It only happens with this Mac OS X version.

--- news://freenews.netfront.net/ - complaints: address@hidden ---


reply via email to

[Prev in Thread] Current Thread [Next in Thread]