help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: emacs-module is not GPL compatible (Windows)


From: Óscar Fuentes
Subject: Re: emacs-module is not GPL compatible (Windows)
Date: Sat, 01 Oct 2016 03:21:40 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/25.1.50 (gnu/linux)

Óscar Fuentes <address@hidden> writes:

> Try changing
>
> int plugin_is_GPL_compatible;
>
> to
>
> __declspec(dllimport) int plugin_is_GPL_compatible;
>
> Probably you will also need to change
>
> int
> emacs_module_init(struct emacs_runtime *ert)
>
> to
>
> int __declspec(dllimport)
> emacs_module_init(struct emacs_runtime *ert)

Sorry. I'm half-asleep. Please change the dllimport above with
dllexport.




reply via email to

[Prev in Thread] Current Thread [Next in Thread]