help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: An unwonted warning I constantly get about fontsets when I start Ema


From: Eli Zaretskii
Subject: Re: An unwonted warning I constantly get about fontsets when I start Emacs
Date: Sun, 28 May 2017 18:41:00 +0300

> From: Göktuğ Kayaalp <address@hidden>
> Cc: address@hidden
> Date: Sun, 28 May 2017 17:32:13 +0300
> 
> >> So running the build after setting LC_ALL=C should fix the problem.
> 
> I've tried this:
> 
> git clean -x -f -f
> ./autogen.sh all
> ./configure --prefix=$HOME/local --with-x-toolkit=yes --with-modules \
>           --with-file-notification=yes --with-mailutils ;
> LC_ALL=C make
> ./src/emacs -Q
> 
> And this has fixed the problem (i.e. no warnings anymore, built today's
> master).  So now I'm not sure if this is a bug that I've triggered, or a
> mistake in my build procedure.  If I'm not told otherwise, I'll file a
> bug report when I have time.

Please try this:

  . go to the admin/unidata directory of the Emacs source tree
  . type the following command from the shell prompt:

     make -W Blocks.txt

This should regenerate lisp/international/charscript.el.  Please see
if it has the same problem with dotless i you had originally.  If it
does, then repeat the same command, this time setting LC_ALL=C, like
this:

     LC_ALL=C make -W Blocks.txt

This should again regenerate charscript.el, but with the correct
script names, using the Latin i letter.

If indeed you see what I describe above, please file a bug report with
this information.  Thanks.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]