help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: TRAMP and Ruby mode, tabs not being honored


From: Michael Albinus
Subject: Re: TRAMP and Ruby mode, tabs not being honored
Date: Mon, 20 Nov 2017 10:15:57 +0100
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/27.0.50 (gnu/linux)

Kevin Faulkner <address@hidden> writes:

Hi Kevin,

[pls keep address@hidden in Cc, for the archives]

>> I have tried to reproduce the problem with the most simple
>> configuration. I have written a file ~/tmp/foo.el:
>> 
>> --8<---------------cut here---------------start------------->8---
>> (setq indent-tabs-mode t
>>       tab-width 3)
>> (add-hook 'ruby-mode-hook
>>        (lambda ()
>>          (setq indent-tabs-mode t
>>                tab-width 2)))
>> --8<---------------cut here---------------end--------------->8---
>> 
>> Then I have opened Emacs 27 with a test ruby file, simulating the sshx
>> method:
>> 
>> $ ~/src/emacs/src/emacs -Q -l ~/tmp/foo.el -l tramp /sshx::~/tmp/estcall.rb
>> 
>> When I edit estcall.rb, and press <RET> after a block, <TAB> is inserted.
>> 
>> Could you, pls, check this recipe in your environment?
>
> Michael, thank you for looking into this, I believe you have fixed my issue
> I tried to load this as you specified, should I keep this loaded in my 
> .dirs-local.el or my local .emacs (init)?

It depends. If you want ruby-mode always use these settings, you could
put the code into your .emacs. Directory local settings are useful for a
kind of "project specific" settings, i.e. if the settings shall be
applied only to files at a given location.

> What was I doing incorrectly?
> I have tried to remove the "-Q", and I still load the file in using -l,
> and I don't think it works, does that mean it could be one of my
> packages that I have installed? I have a few, as i think you can see in
> the configuration post above, but I don't think they are too out of the
> ordinary. Should I consider upgrading?

Using recent package versions might help. If it doesn't, you must bisect
your config. Comment out all loaded packages and half of your .emacs,
start Emacs again. If the problem still exist, it is in the active part
of your .emacs, otherwise it is in the commented part. Continue to
bisect with the non-working part, and so on.

If it isn't your .emacs, then load one package after the other, and
retest.

This way you shall be able to identify the culprit.

> Again, thank you for your time Michael (and others reading this)
>
> -Kevin

Best regards, Michael.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]