help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Tramp access to Android?


From: Michael Albinus
Subject: Re: Tramp access to Android?
Date: Thu, 03 Jan 2019 00:01:26 +0100
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/27.0.50 (gnu/linux)

Skip Montanaro <address@hidden> writes:

Hi Skip,

> Prompted by the discussion about calendar access between Emacs
> (presumably running on a "big" computer of some sort) and Android, I
> recently tried unsuccessfully to access files on my Android phone from
> my Linux laptop. I had installed SimpleSSH on the phone, and can ssh
> into it from the shell prompt. Tramp prompts for a password (which is
> accepted, I believe), but hangs after finding a remote shell prompt.
> Here's the output from my *Messages* buffer:
>
> Tramp: Opening connection for 192.168.97.156#2222 using ssh...
> Tramp: Sending command ‘exec ssh  -p 2222 -o ControlMaster=auto -o
> ControlPath='tramp.%C' -o ControlPersist=no -e none 192.168.97.156’
> Tramp: Waiting for prompts from remote shell...
> Tramp: Sending password [2 times]
> Tramp: Waiting for prompts from remote shell...done
> Tramp: Found remote shell prompt on ‘192.168.97.156’
> Tramp: Opening connection for 192.168.97.156#2222 using ssh...failed
> Quit [2 times]
>
> tramp-verbose was set to 10. Should I try 11? :-)

But then I would like to see the complete Tramp debug buffer.

You could set tramp-verbose to any value larger than 10. But Tramp won't
change its behavior, 10 is the largest value it cares about.

Btw, have you tried the "adb" method instead of "ssh", accessing your
Android device?

> Thx,
>
> Skip

Best regards, Michael.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]