[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

pb linking with libobjc.a under msys

From: Fred Klein
Subject: pb linking with libobjc.a under msys
Date: 9 Jun 2003 03:41:34 -0700

I just installed Install-GNUstep-Development-Environment-0.4.1.exe
(many thanks to Adam Fedor for the link) 
and tried to compile and link 2 Objective-c (.m) files. Compilation
was ok.
Here's the error when linking.

$ gcc -lobjc HelloObjC.o main.o
HelloObjC.o(.text+0x15):HelloObjC.m: undefined reference to
HelloObjC.o(.data+0xd4):HelloObjC.m: undefined reference to
main.o(.text+0x3f):main.m: undefined reference to `objc_get_class'
main.o(.text+0x4a):main.m: undefined reference to `objc_msg_lookup'
main.o(.text+0x60):main.m: undefined reference to `objc_msg_lookup'
main.o(.text+0x8f):main.m: undefined reference to `__objc_exec_class'

I've tried to copy libobjc.a and libiconv.a from
but that did not help
Thanks in advance for your assitance.
Regards - Fred

reply via email to

[Prev in Thread] Current Thread [Next in Thread]