[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: No font when launching a test app

From: Nicolas Girard
Subject: Re: No font when launching a test app
Date: Thu, 19 Jun 2003 22:27:22 +0200
User-agent: Pan/0.14.0 (I'm Being Nibbled to Death by Cats!)

On Thu, 19 Jun 2003 21:41:13 +0200, Alexander Malmberg wrote :

> Nicolas Girard wrote:
> [snip]
>> I decided to follow the FAQ by using the art backend. I did a first
>> attempt to do a
>>    configure --enable-graphics=art && make
>> which failed because of some changes in libfreetype2 (I use version
>> 2.1.3).
>> I googled a little and learned that FTC_ImageDesc has been replaced
>> by FTC_ImageTypeRec.
>> I had to modify gnustep-back-0.8.6/Source/art/ftfont.m as a
>> consequence ; you'll find a diff at the end of this message.
> Thanks, but there have a couple of patches floating around already; see
> for more information
> about it.
Oh, OK, i didn't know about this page ; anyway i knew my diff wouldn't be
of any help, it was just meant to be illustrative :-)
>> Then I succeeded in compiling gnustep-back for the use of the art backend,
>> removed the font cache once again and ran font_cacher.
> back-art uses .nfonts and not font_cacher, so running it has no effect.
>> Now, when i launch my sample NSApplication, i get a *black* window (vs
>> white before), still containing nothing but a grey button. The progress is
>> in the fact that there's now 'OK' written in light grey (hardly unreadable) 
>> in
>> the button...
> Which sample app is this? If it runs and displays text, things are
> probably working. 
It is the one described at
It is supposed to display a simple string and a return button ; as the
window i get is entirely black i can read nothing but i guess the text is
here, anyway

I suggest testing a real app.
Right. I tried the calculator from gnustep-examples. It works in the sense
that the calculator appears. But either the buttons or the menus are
unreadable (light grey text over grey colour) and nothing is visible in
the calculator 'panel'

I also noticed that for every app i run, i get the error message:
Failed to locate strings file Localizable


----== Posted via Newsfeed.Com - Unlimited-Uncensored-Secure Usenet News==---- The #1 Newsgroup Service in the World! >100,000 
---= 19 East/West-Coast Specialized Servers - Total Privacy via Encryption =---

reply via email to

[Prev in Thread] Current Thread [Next in Thread]