[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Building GNUstep on Darwin/x86

From: leeg
Subject: Re: Building GNUstep on Darwin/x86
Date: Thu, 04 Mar 2004 04:34:11 +0000
User-agent: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.0.0) Gecko/20020611

Adam Fedor wrote:

On Tuesday, March 2, 2004, at 02:21 PM, Graham J Lee wrote:

It strikes me that this is an issue with the Apple dyld, but there doesn't seem to be a ./configure flag (I guess it would be in -gui, as that's where libtiff seems to get referenced) to force static linking. Any idea how I can get around/solve this problem?

GNUstep doesn't (intentionally) set the compatibility version for libtiff, so it must be either a problem with how the libtiff library is compiled or perhaps some automatic thing that happens when it is linked with gnustep-gui.

I haven't seen this, but I only have a static libtiff. Perhaps if you have the static version you could remove or rename the dynamic one.

Great! That worked - I edited the configure script of libtiff so that it would always fail when checking for DSO support, so that it built a static libtiff. Now I have GNUstep/Darwin! The only major problem now is that freetype won't build, so I can't use the PDFKit. This has meant that building GWorkspace was a bit kludgey and it's prone to dying, but at least I have my GNUstep now :-)



reply via email to

[Prev in Thread] Current Thread [Next in Thread]