[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Weird TLS Compression Error

From: Dash Shendy
Subject: Re: Weird TLS Compression Error
Date: Mon, 23 May 2011 19:00:46 +0200
User-agent: Crow/1.0

Here's my Virtual host setup:

GnuTLSCache memcache ""
GnuTLSCacheTimeout 600

    GnuTLSEnable on
    DocumentRoot /xxx/xxx/xxx/
    GnuTLSCertificateFile /xxx/xxx/xxx/
    GnuTLSKeyFile /xxx/xxx/xxx/
    LogLevel debug
    ErrorLog /xxx/xxx/xxx/
    CustomLog /xxx/xxx/xxx/ combined

I have tried with various Priorities to no avail.

This started happening after upgrading both GnuTLS (2.12.x) n mod_gnuTLS
(was 0.5.5).

As far as I understand the error message "no compression overlap" is
similar to "no cypher overlap".
That is, there's no common encryption/compression algorithm.

I have switched off apache's mod_deflate, as well as php's output
buffering and zlib.compression which I thought might be causing this.

u can actually try this for yourself at either

I am using self-signed certificates, but I doubt that this could be
causing the issue?

Thank you so much for your time and help, it is greatly appreciated.

P.S. I heard you mention that you are quite busy with GnuTLS development
and can not afford the time to maintain mod_gnutls, and unless you find
someone to maintain it, this module is unmaintained.
      I would love to get involved and contribute, please let me know
what I can do to help (I do know how to code in C but I do not believe I
have the Mathematical background required,
      and do not want to introduce bugs or weaken the security as it
happened with Debian's implementation of OpenSSL a while back, but
please do let me know if I can get involved somehow).

Dash Shendy

reply via email to

[Prev in Thread] Current Thread [Next in Thread]