help-gsl
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Help-gsl] Matrix / Vector multiplication


From: Paulo Jabardo
Subject: Re: [Help-gsl] Matrix / Vector multiplication
Date: Sun, 11 Feb 2007 14:56:01 -0300 (ART)

The BLAS/LAPACK has a naming convention. The ge part
means GEneral matrix. Other possibilities are sy for
SYmmetric matrices (stored in standard matrix format).
Then there are he for HErmitian, gb for General
Banded, sp for Symmetric Packed matrix, and there are
several other possibilities. That's why the somewhat
'clumsy' naming. BLAS/LAPACK provide very efficient
and *tested* algorithms. There are several optimized
libraries for specific hardware (check out intel MKL,
AMD acml, Goto Blas and atlas).

Paulo

 
--- Patrick Alken <address@hidden>
escreveu:

> > gsl_blas_dgemv?!?  Holy smokes!  No wonder I had a
> hard time finding it.
> > Has anyone thought of renaming this function
> something like
> > "gsl_matrix_multiply()"?
> 
> The "basic" linear algebra functions like
> matrix*matrix, matrix*vector
> etc are done in a separate "BLAS" (Basic Linear
> Algebra Subprograms)
> library. The naming convention is confusing since I
> believe its
> from the old fortran conventions, but the "mv" means
> matrix*vector.
> The "d" means double precision and I don't off hand
> know what the ge
> means, but you can read the blas docs for more info.
> 
> 
> _______________________________________________
> Help-gsl mailing list
> address@hidden
> http://lists.gnu.org/mailman/listinfo/help-gsl
> 


__________________________________________________
Fale com seus amigos  de graça com o novo Yahoo! Messenger 
http://br.messenger.yahoo.com/ 




reply via email to

[Prev in Thread] Current Thread [Next in Thread]