[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Help-gsl] problems raised by GPL v3 in GNU GLS

From: Pablo De Napoli
Subject: [Help-gsl] problems raised by GPL v3 in GNU GLS
Date: Wed, 2 Jan 2008 23:37:54 -0200
User-agent: KMail/1.9.6 (enterprise 0.20070907.709405)


I want to make an observation concerning the change in GNU GSL 
licence (in GNU GSL-1.10) from version 2 to version 3.
In the GNU GSL website,

(Before you keep reading, let me tell you that I'am a strong supporter 
of frree software in general, and of the GPL in general).

The release anoucement says
"The license has been updated to GNU GPL version 3.  Programs using the
library should be updated to the same version of the license."

Reading that mail it may seem that GPL 3 is just an upgrade of GPL 2.
But it is not because acording to

both licences are indeed incompatible.

"Is GPLv3 compatible with GPLv2?

    No. Some of the requirements in GPLv3, such as the requirement to provide 
Installation Information, do not exist in GPLv2. As a result, the licenses 
are not compatible: if you tried to combine code released under both these 
licenses, you would violate section 6 of GPLv2.

    However, if code is released under GPL “version 2 or later,” that is 
compatible with GPLv3 because GPLv3 is one of the options it permits."

Now this raises the following issue: some proyects incorporate the GNU 
GSL and also some other libraries that are released under the GNU GPL 
version 2 only
(One example is Sage, that I think that
is indeed a very important project, as it covers something that was missing
 in free software: a software integrating many of the free software
projects for doing mathematics). Another example mightbe Labplot

In some cases, the authors of the other libraries might want to change 
its licence to GPL v3, some other perhaps no, and in other cases might be 
very difficult to contact all the copyright holders (copyright might be spread 
over hundres of people).

Then, that kind of project won't be able to use the new version of the 
GNU  GSL (even thought  that version is indeed binary compatible, and 
mostly a bug-fix release over 1.9)

For project using gnu gsl (that mostly are related to mathematics or
 numerical analysis), the issues that GPL v3 was designed to address 
seem to be irrelevant. What has to do gsl with DRM ?

So I see that change in the licence can create legal troubles to free 
software projects without any protection for them. Is it reasonable to use
GPL v3 for all projects, regardless of the legal incompatibilities this 
might create?

I don't know if that is possible, but I would suggest reconsider relicencing 
GNU GSL under GPL v2 or any later version. This would avoid a lot of 
troubles to people developing free software for mathematics.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]