[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug in gnumake?? Using eval with wildcard function

From: hans . peter . van . lohuizen
Subject: bug in gnumake?? Using eval with wildcard function
Date: Fri, 10 Oct 2003 16:22:34 +0200


I am not sure whether the descibed below is a bug or that I missed something?
Could somebody tell me that?

Thanks a lot!

Hans Peter.

I use gmake 3.80.

I have the following lines to generate a wildcard in a set of rules preceeded by a path added via %:

tmp = $(wildcard cmd/*.tcl)

DEP_CMD=$(foreach OBJ, % ,$(addprefix %, $(tmp)))

The wildcard failes because it is only filled in once for the first % only.

So I tried to use the eval function to re-evaluate the wildcard for all separate %:

DEP_CMD=$(foreach OBJ, % ,$(addprefix %, $(eval $$(tmp)) ))

But now I get the message: "missing separator"

I also tried the value function:

DEP_CMD=$(foreach OBJ, % ,$(addprefix %, $(eval $(value tmp) ) ))

But still get the missing separator message.

Can somebody tell me what is wrong?

Thanks a lot!

Hans Peter.
Help-make mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]