[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Shell command is acting strange.

From: Howard Olson
Subject: Shell command is acting strange.
Date: Tue, 13 Jun 2006 10:43:58 -0600

I am been searching the list archives and have still not been able to
get make to function properly.

I have cygwin on Win 2000 with make 3.78.1.

I was having trouble getting the shell to be cmd.  If I put SHELL :=
cmd.exe in the makefile that seems to do the job.  I can echo $(SHELL)
and see c:/WINNT/system32/cmd.exe.   If I put the SHELL := cmd.exe in a
top level make the SHELL variable does not appear to be passed down to
sub-makes.  The echo $(SHELL) comes out as c:/WINNT/system32/sh.exe.

I have tried to play around with my path.  That seems to have some
affect but my make still fails.

If the shell is set to sh then the error I get is a syntax error on the
following line 
    if not exist dir/  mkdir $(SOMEDIRNAME)

This of course does not work in sh.

Once I get the SHELL to be cmd.exe I get a different error.

Using make -d I see:

Creating temporary batch file c:\Temp\
echo c:/WINNT/system32/cmd.exe  (this is coming from my echo command)
A subdirectory or file .exe already exists.
Error occurred while processing: .exe
A subdirectory or file c:\Temp\ already exists.
Error occurred while processing: c:\Temp\
make:  *** [debug] Error 1

The c:\Temp directory exists and is empty.  I am sure I am missing
something simple but at this point I can not see it.

Howard Olson

reply via email to

[Prev in Thread] Current Thread [Next in Thread]